National Monte Carlo Owners Association

It is currently Sun Dec 17, 2017 11:51 am

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Dash lights not working
PostPosted: Fri Jun 09, 2017 2:01 pm 
Offline

Joined: Thu Jun 01, 2017 5:23 pm
Posts: 5
I have an 84 SS, All of the exterior lights work. When I put the headlights on the dash lights don't work. I have changed the light switch, checked the instrument fuse, checked all of the dash bulbs. I am suspecting that the copper strips behind the dash might have a break in one of the strips. Has anyone had this problem? Any suggestions are appreciated.


Top
 Profile  
Reply with quote  
PostPosted: Sun Oct 29, 2017 10:22 pm 
Offline

Joined: Fri Oct 03, 2008 9:27 pm
Posts: 267
Location: PITTSBURGH,PA
There are foam strips on either side of the flexable copper circuit board that put pressure to the connector terminals. The foam deteriorates loosening the connection causing heat worping the flex circuit board.


Top
 Profile  
Reply with quote  
PostPosted: Sun Oct 29, 2017 11:03 pm 
Offline

Joined: Fri Oct 03, 2008 9:27 pm
Posts: 267
Location: PITTSBURGH,PA
https://www.dixierestorationdepot.com/P ... EPRO&d=948


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group